Database provider planned maintenance
Incident Report for Hindsight Software
Resolved
This incident has been resolved.
Posted about 2 years ago. Apr 24, 2015 - 10:50 UTC
Monitoring
Our database provider is undergoing planned maintenance, access to Behave Pro may be intermittent until 11 AM (GMT). We apologise for any inconvenience caused.
Posted about 2 years ago. Apr 24, 2015 - 07:43 UTC