Specification Page is unavailable for browsing
Incident Report for Hindsight Software
Resolved
Customers using JIRA Service Desk please contact support if they experience any outstanding issues
Posted almost 2 years ago. Oct 13, 2015 - 09:50 UTC
Identified
Customers using JIRA Service Desk are only impacted due a regression within Service Desk
Posted almost 2 years ago. Oct 13, 2015 - 08:43 UTC
Investigating
The Specification page is not loading properly due to no projects being listed by JIRA. We are currently investigating the issue.
Posted almost 2 years ago. Oct 13, 2015 - 06:45 UTC