Degraded performance
Incident Report for Hindsight Software
Resolved
Javascript bug has been squashed
Posted about 1 year ago. Oct 19, 2016 - 09:45 UTC
Identified
Experiencing degraded performance due to a javascript exception
Posted about 1 year ago. Oct 19, 2016 - 09:34 UTC