Behave Pro Outage
Incident Report for Behave Pro
Resolved
This incident has been resolved.
Posted May 04, 2022 - 11:23 BST
Investigating
We are currently investigating an issue causing the Requirements page and Acceptance Criteria not to load.
Posted May 04, 2022 - 09:54 BST
This incident affected: Behave Pro Jira App (US Region, European region, Australia region).